ssh public key and google authenticator

Posted: 4th Февраль 2019 by shmyak in Пингвин
Комментарии к записи ssh public key and google authenticator отключены

/etc/ssh/sshd_config

ChallengeResponseAuthentication yes
UsePAM yes
AuthenticationMethods publickey,keyboard-interactive:pam
PasswordAuthentication no

/etc/pam.d/sshd

#@include common-auth
auth required /usr/local/lib/security/pam_google_authenticator.so

Туннель ssh

Posted: 12th Апрель 2018 by shmyak in Пингвин
Комментарии к записи Туннель ssh отключены

Дано: сервер локальной сети ourproxy.provider.ru, доступный извне.

Требуется: получить из дома доступ к ресурсам внутри локальной сети, например,
к интранет-серверу 10.10.5.1:80

Решение: выполнить на домашней машине команду, пробрасывающую туннель к
искомому IP-адресу через ourproxy.provider.ru:

ssh -f -N user@ourproxy.provider.ru -L 8080:10.10.5.1:80

Опция -f говорит ssh, что после соединения нужно уйти в background.
Опция -N указывает, что никаких команд выполнять не нужно
Ключ -L означает, что соединения к localhost на порт 8080 нужно перенаправлять
на 80 порт IP-адреса 10.10.5.1

Таким образом, набирая в браузере адрес http://localhost:8080, попадаем на нужный сервер.

https://www.opennet.ru/tips/1691_ssh_tunnel_socks.shtml

linux vlan

Posted: 28th Июнь 2017 by shmyak in Пингвин
Комментарии к записи linux vlan отключены

loose_binding on|off gvrp on|off
ingress-qos-map FROM:TO egress-qos-map FROM:TO

how to disable ipv6

Posted: 28th Июнь 2017 by shmyak in Пингвин
Комментарии к записи how to disable ipv6 отключены

Here’s how to disable the protocol on a Red Hat-based system:

To re-enable IPv6, issue the following commands:

Here’s how to disable the protocol on a Debian-based machine.

1. Open a terminal window.

2. Issue the command sudo nano /etc/sysctl.conf

3. Add the following at the bottom of the file:

4. Save and close the file.

5. Reboot the machine.

To re-enable IPv6, remove the above lines from /etc/sysctl.conf and reboot the machine.

samba server

Posted: 22nd Апрель 2017 by shmyak in Пингвин
Комментарии к записи samba server отключены

Add Samba users

Samba uses it’s own password system so users need to be added by root. Note that the users have to exist in /etc/passwd

You will be prompted for a password for each of those users.

To list existing Samba users:

Restart the Samba daemon

or, if you are using systemd

Try to access the shares (as a normal user)

Try locally first, then from another machine on the network which also installed samba client. When prompted, use the password entered when adding the user to Samba.

To access my share:

To access your share:

To access our shared(!) share:

#https://wiki.debian.org/SambaServerSimple

mount smb dir from remote machine:

Второй вариант без авторизации.

OrangePi PLUS. WiFi

Posted: 6th Октябрь 2016 by shmyak in Пингвин

To enable wifi connection from command line run: sudo nmcli -a d wifi connect and enter your wifi credentials

Зло! apt-get remove network-manager (:

/etc/wpa_supplicant.conf

/etc/network/interfaces

Fedora:
https://ask.fedoraproject.org/en/question/59278/how-can-i-enable-wpa_supplicant-on-boot/

Лицензии в cisco

Posted: 15th Сентябрь 2016 by shmyak in Пингвин

1. IOS не NPE, т.е. без NPE в назнавнии, т.е., например, вот такой: c2900-universalk9-mz.SPA.151-3.T.bin. У вас — нпе. http://pig.lsd-25.ru/uploads/ios/ (меня разбанили)
2. ИОС не ниже версий: 15.0(1)M4, 15.1(1)T2, 15.1(2)T2, 15.1(3)T. У вас — сами угадаете?
3. Зайти на роутере в привелегированный режим и в режим глобальной конфигурации. Это может быть проблемой. Но это обязательное условие.
4. Ползуясь подсказками (нажимая кнопку «?») написать что-то вроде:
license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
и после вводка каждой из строк согласиться с EULA.
5. Выйти из режима глобального конфигурирования.
6. Сохранить конфигурацию командой copy system:running-config nvram:startup-config
7. Ответить утвердительно на команду reload.
8. Получить профит.

#sh ver

#sh lic

 

http://www.anticisco.ru/forum/viewtopic.php?f=2&t=1615&sid=8efe01d4a3dfc3aa990a78d206f8276f

L2TP over IPsec on Cisco IOS Router

Posted: 15th Сентябрь 2016 by shmyak in Пингвин

Configuration on Cisco IOS router:

version 12.4

!

hostname L2TP

!

!

aaa new-model

!

!

aaa authentication ppp VPDN_AUTH local

!

!

vpdn enable

!

vpdn-group L2TP

! Default L2TP VPDN group

accept-dialin

protocol l2tp

virtual-template 1

no l2tp tunnel authentication

!

!

!

username cisco privilege 15 password 0 cisco

!

!

crypto isakmp policy 1

encr 3des

hash sha

authentication pre-share

group 2

lifetime 86400

!

!

crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set L2TP-Set2 esp-3des esp-sha-hmac

mode transport

!

crypto dynamic-map dyn-map 10

set nat demux

set transform-set L2TP-Set2 L2TP-Set

!

!

crypto map outside_map 65535 ipsec-isakmp dynamic dyn-map

!

!

!

interface Loopback0

ip address 192.168.47.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Loopback1

description loopback for IPsec-pool

ip address 1.1.1.11 255.255.255.255

!

interface FastEthernet0/0

ip address 47.47.47.2 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

crypto map outside_map

!

!

interface Virtual-Template1

ip unnumbered Loopback1

peer default ip address pool l2tp-pool

ppp authentication ms-chap-v2 VPDN_AUTH

!

!

!

ip local pool l2tp-pool 1.1.1.1 1.1.1.10

ip route 0.0.0.0 0.0.0.0 47.47.47.1

!

ip nat inside source list NAT interface FastEthernet0/0 overload

!

ip access-list extended NAT

deny ip 192.168.47.0 0.0.0.255 1.1.1.0 0.0.0.255

permit ip 192.167.47.0 0.0.0.255 any

!

!

!

End

 

https://supportforums.cisco.com/document/9878401/l2tp-over-ipsec-cisco-ios-router-using-windows-8

mjpg-streamer. snapshot.

Posted: 26th Август 2016 by shmyak in Пингвин

script:

#!/bin/bash

filename=$(perl -e «print time»)
foldername=$(date —rfc-3339=date)

curl «http://127.0.0.1:8080/?action=snapshot» > $filename
timestamp=stat -c %y $filename

if ! [ -d/path/to/dir/$foldername ]; then
mkdir /path/to/dir/$foldername
fi

### timestamp
convert $filename -fill black -fill white -pointsize 15 -draw  «text 5,15 ‘${timestamp:0:19}'»/path/to/dir/$foldername/$filename.jpg
###

rm $filename

 

add to crontab:

*/1     *       *       *       *       /snapshot.sh >/dev/null 2>&1

 
Convert to videofile:

ffmpeg -framerate 10 -pattern_type glob -i «*.jpg» out.mkv

Raspberry Pi. mjpg-streamer

Posted: 25th Август 2016 by shmyak in Пингвин

mjpg-streamer.tar

(from http://lilnetwork.com/download/raspberrypi/mjpg-streamer.tar.gz)

sudo apt-get update
sudo apt-get install libv4l-dev libjpeg8-dev subversion imagemagick

sudo ln -s /usr/include/linux/videodev2.h /usr/include/linux/videodev.h

svn co https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer/ mjpg-streamer

cd mjpg-streamer/
make USE_LIBV4L2=true clean all
sudo make DESTDIR=/usr install

sudo cp mjpg_streamer /usr/local/bin
sudo cp -R www /usr/local/www

mjpg_streamer -i «/usr/lib/input_uvc.so -d /dev/video0 -y -r 1280×720 -q 95 -f 4 -l auto» -o «/usr/lib/output_http.so -p 8080 -w /usr/local/www -c user:id»
Не забываем про кривое отображение кавычек и «Х»

sudo mcedit /etc/init.d/mjpg_streamkick

#! /bin/sh
# /etc/init.d/mjpg_streamkick

# Carry out specific functions when asked to by the system
case «$1» in
start)
echo «Starting mjpg_streamkick script»
export LD_LIBRARY_PATH=/usr/local/bin
mjpg_streamer -i «/usr/lib/input_uvc.so -d /dev/video0 -y -r 1280×720 -q 95 -f 4 -l auto» -o «/usr/lib/output_http.so -p 8080 -w /usr/local/www -c user:id» &
;;
stop)
echo «Stopping webcam script»
killall mjpg_streamer
;;
*)
echo «Usage: /etc/init.d/mjpg_streamkick {start|stop}»
exit 1
;;
esac

exit 0
sudo chmod 755 /etc/init.d/mjpg_streamkick
sudo update-rc.d mjpg_streamkick defaults

 

 

mjpg_streamer -i /usr/lib/input_uvc.so -d /dev/video0 -y -r 716×537 -q 90 -f 24 -l auto -o /usr/lib/output_http.so -p 8080 -w /usr/local/www -c usr:pwd

by danjperron

https://www.raspberrypi.org/forums/viewtopic.php?t=48597